El scanner no lee ningún código de barras en el sistema de ManagementPro
Síntomas
Al momento de scanner un código de barras en el sistema de ManagementPro, el scanner no lee el código de barras y no se logra capturar el producto en el sistema
Causa
La actualización de Windows KB4515384 que fue liberada despues del 10 de septiembre del 2019, reconoce el scanner como un dispositivo libusb-win32 y actualiza el controlador, dejando este dispositivo sin funcionalidad.
Solución
Para corregir los controladores que permiten el uso del scanner, debes realziar el siguiente proceso:
Ingresa al Administrador de dispositivos
Para corregir los controladores del scanner vamos a ingresar al Administrador de dispositivos, para ello vamos a presionar el botón derecho del mouse sobre el icono de inicio de windows 10

En el menú que se mostros vamos a buscar la opción de Administrador de dispositivos seleccionamos la opción y presionamos el botón izquierdo del mouse sobre la opción.

Dentro de la pantalla de Administrador de dispositivos, vamos a buscar el dispositivo que se llama libusb-win32 devices

Ya que localizamos el dispositivo libusb-win32 devices, vamos a expandirlo para ver el dispositivo que se llama BETTER_USB_HS, este dispositivo es nuestro scanner.

Ahora seleccionamos el dispositivo con nombre BETTER_USB_HS, y presionamos el botón derecho del mouse sobre el nombre.
Al realizar este proceso, nos mostrara un menu contextual, en cual vamos a buscar la opción Propiedades y la seleccionamos.

Dentro de la pantalla de propiedades, nos vamos a posicionar en la pestaña que se llama Controlador.
Ahora debemos buscar el botón Actualizar controlador, nos posicionamos sobre el botón lo seleccionamos con el botón izquierdo del mouse.

En la pantalla de busqueda de controladores, vamos a seleccionar la opción Buscar software de controlador en el equipo. Posicionamos el mouse sobre esta opción y presionamos el botón izquierdo del mouse para continuar.

En la pantalla de busqueda de controladores dentro de una ubicación en el equipo, vamos a seleccionar la opción Elegir en una lista de controladores disponibles en el equipo. Posicionamos el mouse sobre esta opción y presionamos el botón izquierdo del mouse para continuar.

En la pantalla para Seleccionar un controlador del dispositivo, vamos a seleccionar el controlador Dispositivo de teclado HID o el controlador Dispositivo de entrada USB, posicionamos el mouse sobre cualquiera de estas dos opciones y presionamos el botón siguiente para continuar.

El sistema operativo iniciara el proceso de instalación del controlador del dispositivo, debemos esperar unos minutos para que finalice la instalación y continuemos con el proceso.

Al finalizar la instalación, el sistema operativo Windows 10 nos enviara una pantalla informando que se ha finalizado la instalación del dispositivo. Presionamos el botón Cerrar para finalizar.

Ya que concluimos la instalación, vamos a verificar que ya se encuentre nuestro scanner configurado en nuestro equipo, para ello vamos a buscar nuestro dispositivo dentro del apartado de Teclados, en el cual debemos poder observar un dispositivo llamado Dispositivo de teclado HID

Ya que hemos finalizado con la instalación del controlador, podemos realizar pruebas de nuestro scanner, el cual debe de funcionar sin dificultades.
↑ Volver arriba